Updating Java to 1.7 Breaks Dell EqualLogic VSM

I loathe updating Java because you never know what it will break. This morning, it was the Dell EqualLogic VSM plug-in for vCenter.

Upon launching the plug-in, I got these errors:

Image

Image

I thought to disable the current version and enable the previous version, but there is a way to add this URL as an exception.

Launch the Java control panel (I’m running 2008 R2) and click on the security tab.

Click the edit Site List button:

Image

Add the URL in the above mentioned error, by clicking Add, then typing in the URL.I also added the IP to vcenter as well. Click OK.

Image

Image

One more warning about the HTTP location you’ve entered. Just click continue. Apply the changes and close the java applet. Be sure to close the vCenter client as well.

Launch the client and log into VSM as usual.

Update- info on Windows 7

In Windows 7, there is no exception list under the security tab. To add your site to an exception list, you can create an exception.sites file and add the URL.

win7-java-securitytab

Browse to this location: C:\Users\username\AppData\LocalLow\Sun\Java\Deployment\security

If  there is a file named exception.sites, add the URL to that file. One URL per line.

If not, you can create it and add your URL.

exception-site

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s